We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Cannot scroll Gridview with items, when using Charts

Thread ID:

Created:

Updated:

Platform:

Replies:

114714 Dec 5,2013 10:28 AM UTC Jan 23,2014 01:12 PM UTC WinRT 5
loading
Tags: Chart
Thierry Maurel
Asked On December 5, 2013 10:28 AM UTC

Hello,
I use the charts controls in a gridview template, each chart data are in a viewmodel's list (using prism) and are binding to the Series member.
Everything works fine, but I cannot use the charts as objects to scroll with the finger in the gridview.
I don't find what is the option to enable this feature.
Regards
Thierry
 

Muneesh Kumar G [Syncfusion]
Replied On December 6, 2013 12:51 PM UTC

Hi Thierry,

Thanks for using Syncfusion products.

We are unable to get your exact requirement. Please give more information about your requirement. This would be helpful for us to serve you.

Please let us know if you have any queries.

Regards,

Muneesh Kumar G.

 


Thierry Maurel
Replied On January 13, 2014 09:25 AM UTC

Hello,
thank you for your answer, I will try to be more explicit..
I use a scrollviewer, which contains an horizontal stackpanel, which contains several syncfusion charts.
The number of charts is important so the stackpanel is more large than the screen.
In fact, if the charts are enabled, the user cannot scroll with finger to move from left to right, when he touch a chart. The 'click' is not sent to the scrollviewer so the scroll is stopped...
A workaround is to disable all charts, but I cannot attach a 'tapped' event to the charts..

Any solution ?
Regards
Thierry

Karthikeyan V [Syncfusion]
Replied On January 18, 2014 06:30 AM UTC

Hi Thierry,

Thanks for using Syncfusion products.

We have analysed the reported requirement. You can able to achieve this requirement by help of ScrollViewer property set with PanningMode as Both.

Code Snippet [XAML]:

  <ScrollViewer PanningMode="Both" HorizontalScrollBarVisibility="Visible">

 

Please let us know if you have any query.

Thanks,

Karthikeyan V.


Thierry Maurel
Replied On January 20, 2014 10:32 AM UTC

Hi Karthikeyan,
ok, my fault, there was a change in the XAML file of our product, we decided using ListViewer instead of ScrollViewer to add several block of data (=charts or other) from an ObservableCollection, so the solution you proposed is not valid...
In fact, there is an internal scrollviewer into a ListViewer, but I cannot set the paddingmode attribute as ScrollViewer.PaddingMode in my ListViewer, maybe a difference of .net version ?
Regards
Thierry


Karthikeyan V [Syncfusion]
Replied On January 23, 2014 01:12 PM UTC

Hi Thierry,
Sorry for the inconvenience caused.
We have analysed the reported requirement. You can achieve your requirement by setting the ManipulationMode as System.
Code Snippet [XAML]:
    <syncfusion:SfChart ManipulationMode="System"  />
Please let us know if you require further assistance on this.
Thanks,
Karthikeyan V.


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;