We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Very unpleasant Help Experience in Essential Studio v11.3.0.30

Thread ID:

Created:

Updated:

Platform:

Replies:

111110 Sep 8,2013 03:46 PM Oct 6,2013 05:27 AM General Discussion 2
loading
Tags: General Discussion
Winfried Andreas
Asked On September 8, 2013 03:46 PM

Hello,

  • VS2012 Class Reference is missing completely in Help Viewer 2.0, no section in the content treeview. The entry is present and visible under "Manage Content"
  • VS2012 Userguide does not show all topics, when navigating via hyperlinks. Instead it gives you a "Cannot find requested topic on your computer" (Example Path: Essential Common\Installation and Deployment\System Requirements or "Installation").When navigating via conten tree view, the item shows up
  • VS2012 Content management of the user guide is simply unmanageable, instead of having one section for the user guide, it is split into 92(!) separate entries
  • The behaviour can be reproduced on two machines, one running with windows7, the other windows8. I have already installed the help setups twice, same result
  • Both machines run vs2012 update3
  • VS2010 Class Reference and User guide are correctly installed into subfolders named Help2010, but user guide shows up in the startmenu under Help2012
  • Trying to start user guide from syncfusions start menu entry results in the message, that help viewer 1.1 or 2.0 is needed (eventhough the first on is clearly present, because the system is runnung vs2010 sp1)
  • VS2010 user guide shows up in Help viewer 1.1 , when starting help viewer directly. Doing so, the help system seems to behave correctly contrasting the vs2012 behaviour (clickíng hypertext links)
  • VS2010 Class Reference shows up in Help viewer 1.1 and behaves correctly as well
  • VS2010 user guide cannot be installed on system running already vs2012 user guide, why is this (i have a dual vs2010/2012 installation as well))? The missing shown says something like "The ug setup has been terminated because a previous version of ug is installed ....", which is not the case, because only the vs2012 ug is installed in the exact same version 11.3.0.30.
  • Vs2010 Class Reference setup in contrary can get started with VS2012 CR already present, seems to be contradictory for me
  • This behaviour can be reproduced as well on the above stated two machines

This issues are very unpleasant, especially because setting up the complete help files really takes a lot of time when building the indexes. Reinstallation is therefore not a really funny thing to go through.

In my opinion, the help system should clearly be reviewed more carefully before deployment. Mistkes here are very much harder to tolerate then for example, bugs in the samples section.

Best regards, W. Andreas



Vadivel N [Syncfusion]
Replied On September 15, 2013 06:39 AM

Hi Winfried Andreas, 


We deeply regret for the inconvenience caused. 


Currently we are checking the reported issue with our 'help documentation setups' in the Visual Studio 2012 update3 installed machine. We need some time to analyze this. We will get back to you with the complete details once we checked the reported issue in both Windows 7 and Windows 8 machine.

 

Please let me know if you have any questions. 


Regards,

Vadivel N


Vadivel N [Syncfusion]
Replied On October 6, 2013 05:27 AM

Hi Winfried,

 

We regret for the inconvenience caused.

 

Regarding "VS2012 Class Reference is missing completely in Help Viewer 2.0, no section in the content treeview. The entry is present and visible under "Manage Content"", We afraid that we are unable to reproduce the reported issue at our end. So, we kindly request you to try the manual registration steps mentioned below and let us know if this helps you. Please make sure that all the files related to the Class Reference are exists in the Class Reference setup installed location before started to register the help contents in help viewer manually.  Please follow the below step to remove the older version contents from help viewer(if it exists).

 

i)                    Navigate to Help option -> Select Add and Remove Help Content -> Select the 'Remove' options for installed Syncfusion Class Reference documentation contents and click 'Update'(find at bottom of right corner) . In order to ensure only the Syncfusion Class Reference documentation contents remove from help viewer, while selecting the ‘Remove’ option please check the installation source path as same as respective Class Reference documentation setup installed path as mentioned in the screenshot.

 

 

Please follow the below step to register the latest version v11.3.0.30 Class Reference contents in help viewer.

 

ii)                    Navigate to Help option -> Select ‘Add and Remove Help Content’ - >Microsoft Help Viewer 2.0 will be open. Browse to the Class Reference setup installed location using the browse option and then select HelpContentSetup.msha file and then click Add and then Update. Please refer the below screenshot.

                 

 

 

·         Regarding “VS2012 Userguide does not show all topics, when navigating via hyperlinks. Instead it gives you a "Cannot find requested topic on your computer" (Example Path: Essential Common\Installation and Deployment\System Requirements or "Installation").When navigating via conten tree view, the item shows up”, we have fixed the reported issue and refreshed the User Guide documentation setup in our website.

 

Regarding “VS2012 Content management of the user guide is simply unmanageable, instead of having one section for the user guide, it is split into 92(!) separate entries”, We would like to let you know that this is the default behaviour of our documentation setup. Since we are using hub technique to our documentation contents to show in tree view structure.

 

·         Regarding “VS2010 Class Reference and User guide are correctly installed into subfolders named Help2010, but user guide shows up in the startmenu under Help2012”, please share more details to us which will be helpful for us to investigate further.

 

·         Regarding “VS2010 user guide cannot be installed on system running already vs2012 user guide, why is this (i have a dual vs2010/2012 installation as well))? The missing shown says something like "The ug setup has been terminated because a previous version of ug is installed ....", which is not the case, because only the vs2012 ug is installed in the exact same version 11.3.0.30.”, we would like to let you know that we are unable to install our VS2010 User Guide setup in VS2012 User Guide setup already installed machine. In order to view our User Guide setup contents  in help viewer 1.1 or 2.0, we are providing two different setups(VS2010 and VS2012 User Guide)  with the same content. If we try to install Vs2010 User Guide setup in VS2012 User Guide machine, contents already registered with Help Viewer get conflicted.  This is applicable to Class Reference also.

 

Regarding “bugs in the samples section”, could you please share more details(product, platform)to us which will be helpful for us to investigate further?

 

Please let us know if you need any further assistance on this.

 

Regards,

Vadivel N


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;