We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Can't be set SyncFusionChartAxis.IsLogarithmic in code behind.

Thread ID:

Created:

Updated:

Platform:

Replies:

110541 Aug 11,2013 05:33 AM Aug 13,2013 07:31 AM WPF 1
loading
Tags: Chart
Suneelkumar Ch
Asked On August 11, 2013 05:33 AM

Hi, 
SyncfusionChartAxis.IsLogarithmic property can't be set in the code behind. However this can be set using databinding or using SetValue() method it works. 

Source sample:
chart1.Areas[0].SecondaryAxis.IsLogarithmic = true;

Ths above line leads to following error:   Property or indexer 'Syncfusion.Windows.Chart.ChartAxis.IsLogarithmic' cannot be assigned to -- it is read only

However, the following line works properly:
chart1.Areas[0].SecondaryAxis.SetValue(SyncfusionChartAxis.IsLogarithmicProperty,
                                                                        true);      

Thanks
Suneel

Sheik Syed Abthaheer M [Syncfusion]
Replied On August 13, 2013 07:31 AM

Hi Suneel,

 

Thanks for using Syncfusion products.

 

We have analyzed your query and we would like to inform you that the IsLogarithmic property is an internal set property for internal usage. Hence it worked with binding and throwed exception while setting that property directly. Now we have modified our existing implementation by making this property as ReadOnly property. These changes will be reflected in our upcoming volume release. If we need to set the Logarithmic Axis, we need to use the ValueType property of ChartAxis.

 

Please let us know if you have any queries.

 

Regards,

M. Sheik


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;