We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Dynamically set localization for the schedule control

Thread ID:

Created:

Updated:

Platform:

Replies:

110438 Aug 5,2013 12:28 AM UTC Dec 30,2013 09:57 AM UTC ASP.NET MVC (Classic) 5
loading
Tags: Schedule
Aziz Bouchlarham
Asked On August 5, 2013 12:28 AM UTC

Hi,

The title sums it pretty much all up. Some extra info, i have this settings in my web.config file:

<globalization culture="auto" uiCulture="auto" />

It seems that the schedule control doesn't 'look' for that settings. Is this true? If so, any way to make it 'look' for it?

I rather not bother the user with a dropdownlist, since everything else works just fine with the localizations I have set up.

Velmurugan S [Syncfusion]
Replied On August 8, 2013 01:24 PM UTC

Hi Aziz,

 

Thanks for using Syncfusion products.

 

We regret for the inconvenience caused as we are not able to reproduce the reported issue with the mentioned code and also we have tested with the below code and working fine to us. And also we would like to let you know that you may be missing the “App_GlobalResources” files with the sample. It is mandatory to specify the code to be executed while globalization settings takes place . Please find the below code that we have tested in the sample.

 

<code>

                <globalization uiCulture="fr-FR" culture="fr-FR" />

                <globalization uiCulture="auto" culture="auto" />

<code>

 

kindly let us know if helps and please get back with us some more details like screenshot or sample if you are still facing issues on this.

 

Regards,

Velmurugan.

Aziz Bouchlarham
Replied On August 8, 2013 09:42 PM UTC

Hi,

I do have App_GlobalResources folder included with its sub files.
But why do I need both these settings:

<globalization uiCulture="fr-FR" culture="fr-FR" />

<globalization uiCulture="auto" culture="auto" />

Isn't 'auto' enough for it to decide which one to pick?



Velmurugan S [Syncfusion]
Replied On August 12, 2013 12:59 PM UTC

Hi Aziz,

Thanks for the update,

We are regret for the inconvenience caused. We would like to let you know that the following for using culture change.

 

Query #1:  Isn't 'auto' enough for it to decide which one to pick?

              

                 Yes, the auto is enough for it to decide which one need to pick.

                        <globalization uiCulture="auto" culture="auto" />

Query #2:  When we need to specify the particular culture we can mention like the below.

 

Ex: French culture    =  <globalization uiCulture="fr-FR" culture="fr-FR" />

 

Please let us know if it helps and also please get back with us some more details like screenshots or sample if you are still facing issues on this.

 

Regards,

Velmurugan.


Aziz Bouchlarham
Replied On December 18, 2013 12:08 PM UTC

Hi,

It seems to be that the problem is as follow, when I do this:

SchedulePropertiesModel model = new SchedulePropertiesModel();
model.Localize = Thread.CurrentThread.CurrentUICulture.Name;

Thread.CurrentThread.CurrentUICulture.Name contains "nl-NL".
But App_GlobalResources only has "nl-BE". So it wont load the dutch language. "nl-NL" != "nl-BE".

How to overcome this issue?

Sarath Kumar P K [Syncfusion]
Replied On December 30, 2013 09:57 AM UTC

Hi Aziz,

 

Thanks for using Syncfusion products.

 

We would like to inform you that in order to localize the schedule control with your own required culture names, then those cultures should already been defined in the App_GlobalResources folder of your project. For example, if you need to localize the schedule control in the language “nl-NL”, then the regarding file for it should be present in the App_GlobalResources folder. So we suggest you to add the required resource file for the “nl-NL” culture in the App_GlobalResources folder of your project in order to overcome this issue.

 

Kindly try the above suggestion and let us know, if you need any further assistance on this.

 

Regards,

Sarath Kumar P K


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;