We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

DocIO with Template

Thread ID:

Created:

Updated:

Platform:

Replies:

110384 Jul 31,2013 10:07 PM UTC Mar 27,2014 12:34 AM UTC WinForms 2
loading
Tags: DocIO
Blake Scarlavai
Asked On July 31, 2013 10:07 PM UTC

I'd like to use a template when generating my Word document.  I've been using the AttachedTemplate property and setting UpdateStylesOnOpen which works fine.  The issue is that if I email the document to someone else and they don't have the template, then the document will open without the template styles.  If I set UpdateStylesOnOpen to false then the document doesn't use the template styles either.

Any ideas?

Gunasekaran T [Syncfusion]
Replied On August 7, 2013 07:42 AM UTC

Hi Blake,

Thank you for your interest in Syncfusion products.

We have prepared Windows Store application to illustrate your requirement to copy styles from template to new Word document (Instead of using AttachedTemplate functionality) using DocIO. Please do find the sample from the attachment for your reference. Try the attached sample and let us know if this helps you.

Please let us know if you have any other questions.

Regards,
Gunasekaran



Sample_3ca93e5f.zip

Jack Misiura
Replied On March 27, 2014 12:34 AM UTC

Hi Blake,

Thank you for your interest in Syncfusion products.

We have prepared Windows Store application to illustrate your requirement to copy styles from template to new Word document (Instead of using AttachedTemplate functionality) using DocIO. Please do find the sample from the attachment for your reference. Try the attached sample and let us know if this helps you.

Please let us know if you have any other questions.

Regards,
Gunasekaran



Sample_3ca93e5f.zip

I had a similar question but can't download the sample provided. Keep getting a 403 error whenever I try.


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;