We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

GridGroupingControl AllowRemove overriding ReadOnly flag

Thread ID:





110312 Jul 29,2013 02:30 PM Aug 5,2013 08:52 AM ASP.NET Web Forms (Classic) 4
Tags: GridGroupingControl
Matt Holtz
Asked On July 29, 2013 02:30 PM


Ran into this issue while testing with the gridgroupingcontrol with the allowremove tag overriding the readonly gridcolumndescriptor. For example, when entering edit mode with the following code it functions as intended, with the SID column greyed out. However, when toggling the AllowRemove flag to True it becomes editable.

Is there a proper way to enable removing rows that i'm missing? Should I be using baritems and parsing those instead?

 <syncfusion:GridGroupingControl ID="Testing" runat="server" AutoFormat="Monochrome"
                    EnableCallbacks="False" ShowGroupDropArea="False" DataSourceCachingMode="ViewState" DataMember="DefaultView">
                    <TableDescriptor AllowEdit="true" AllowRemove="false" AllowNew="true">
                            <syncfusion:GridColumnDescriptor MappingName="SID" HeaderText="SID" ReadOnly="true"/>
                            <syncfusion:GridColumnDescriptor MappingName="Name" HeaderText="SiteName"/>

Also, when I hit enter the update processes but doesn't exit the edit mode even though have set event args as per your examples with:
            e.Cancel = true;
            e.Handled = true;
at the end.

Any tips would be appreciated.

Matt Holtz
Replied On July 29, 2013 06:13 PM

Okay figured out the issue to when the control gets rebound it loses it's readonly flag

Eswari S [Syncfusion]
Replied On July 30, 2013 05:02 AM

Hi Matt,


Thank you for using Syncfusion products.


Happy to hear that your issue has been solved.


Please let us know if you need any further assistance.



Eswari S


Matt Holtz
Replied On July 31, 2013 03:13 PM

To assist in those who may run into losing tabledescriptors on setting values to null, the flag you need to set is 
in the ggc declaration. I missed that and that's what was causing all of my issues.


Eswari S [Syncfusion]
Replied On August 5, 2013 08:52 AM

Hi Matt,


Happy to hear that you found resolution.


Please let us know if you need any other assistance.



Eswari S


This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.