We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

DiagramWebControl & PaletteGroupBar on IIS 7.5

Thread ID:

Created:

Updated:

Platform:

Replies:

109268 Jun 5,2013 09:40 AM UTC Jun 7,2013 03:50 AM UTC ASP.NET Web Forms (Classic) 2
loading
Tags: DiagramWebControl
Hayssam Hassan
Asked On June 5, 2013 09:40 AM UTC

Hi,
im trying to deploy my web site on IIS 7.5, its working well but both DiagramWebControl & PaletteGroupBar are not working.
This is my Web.config. i dont know is there is somthing missing?

<?xml version="1.0" encoding="UTF-8"?>
<!--
  For more information on how to configure your ASP.NET application, please visit
  http://go.microsoft.com/fwlink/?LinkId=169433
  -->
<configuration>
  <connectionStrings>
    <add name="KBDConnectionString" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI; database= KBD.mdf;AttachDBFilename=|DataDirectory|KBD.mdf; User Instance=true" providerName="System.Data.SqlClient" />
    <!--<remove name="LocalSqlServer"/>
    <add name="LocalSqlServer" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|KBD.mdf; User Instance=true" providerName="System.Data.SqlClient" />-->
  </connectionStrings>
  <system.web>
    <httpHandlers>
      <add path="ImgRequest.ashx" verb="*" type="Syncfusion.Web.UI.WebControls.Diagram.NodeRenderHandler,Syncfusion.Diagram.Web, Version=10.404.0.71, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89" />
      <add path="PaletteImgRequest.ashx" verb="*" type="Syncfusion.Web.UI.WebControls.Diagram.ThumbNodeRenderHandler,Syncfusion.Diagram.Web, Version=10.404.0.71, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89" />
      <!--<add path="OverviewImgRequest.ashx" verb="*" type="Syncfusion.Web.UI.WebControls.Diagram.OverviewDocumentRenderHandler,Syncfusion.Diagram.Web, Version=10.404.0.71, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89"/>-->
    </httpHandlers>
    <compilation debug="true" targetFramework="4.0">
      <assemblies>
        <add assembly="Syncfusion.Tools.Web, Version=10.404.0.71, Culture=neutral, PublicKeyToken=3D67ED1F87D44C89" />
        <add assembly="Syncfusion.Shared.Web, Version=10.404.0.71, Culture=neutral, PublicKeyToken=3D67ED1F87D44C89" />
        <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
        <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
        <add assembly="Syncfusion.Core, Version=10.404.0.71, Culture=neutral, PublicKeyToken=632609B4D040F6B4" />
        <add assembly="Syncfusion.Shared.Base, Version=10.404.0.71, Culture=neutral, PublicKeyToken=3D67ED1F87D44C89" />
        <add assembly="Syncfusion.Grid.Base, Version=10.404.0.71, Culture=neutral, PublicKeyToken=3D67ED1F87D44C89" />
        <add assembly="Syncfusion.Tools.Base, Version=10.404.0.71, Culture=neutral, PublicKeyToken=3D67ED1F87D44C89" />
        <add assembly="Syncfusion.Diagram.Web, Version=10.404.0.71, Culture=neutral, PublicKeyToken=3D67ED1F87D44C89" />
        <add assembly="Syncfusion.Diagram.Base, Version=10.404.0.71, Culture=neutral, PublicKeyToken=3D67ED1F87D44C89" />
        <add assembly="System.Runtime.Serialization.Formatters.Soap, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
        <add assembly="Syncfusion.Diagram.Windows, Version=10.402.0.71, Culture=neutral, PublicKeyToken=3D67ED1F87D44C89" />
        <add assembly="Syncfusion.Compression.Base, Version=10.404.0.71, Culture=neutral, PublicKeyToken=3D67ED1F87D44C89" />
        <add assembly="Syncfusion.Pdf.Base, Version=10.404.0.71, Culture=neutral, PublicKeyToken=3D67ED1F87D44C89" />
      </assemblies>
    </compilation>
    <authentication mode="Forms">
      <forms loginUrl="~/Account/Login.aspx" timeout="2880" />
    </authentication>
    <membership defaultProvider="KBDSqlMembershipProvider">
      <providers>
        <clear />
        <add name="KBDSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="KBDConnectionString" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="KrallmannBusinessDesigner" />
      </providers>
    </membership>
    <profile defaultProvider="KBDSqlProfileProvider">
      <providers>
        <clear />
        <add name="KBDSqlProfileProvider" type="System.Web.Profile.SqlProfileProvider" connectionStringName="KBDConnectionString" applicationName="KrallmannBusinessDesigner" />
      </providers>
      <!--<properties>
        <add name="UserName" type="String"/>
        <add name="Email" type="String" />
      </properties>-->
    </profile>
    <roleManager enabled="false">
      <providers>
        <clear />
        <add name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="ApplicationServices" applicationName="/" />
        <add name="AspNetWindowsTokenRoleProvider" type="System.Web.Security.WindowsTokenRoleProvider" applicationName="/" />
      </providers>
    </roleManager>
    <customErrors mode="Off" />
  </system.web>
  <system.webServer>
    <modules runAllManagedModulesForAllRequests="true" />
        <validation validateIntegratedModeConfiguration="false" />
        <defaultDocument>
            <files>
                <add value="Account/Login.aspx" />
            </files>
        </defaultDocument>
        <directoryBrowse enabled="false" />
  </system.webServer>
</configuration>


Hayssam Hassan
Replied On June 5, 2013 10:27 AM UTC

Hi i found the solution and its working well

Amsath Ali M [Syncfusion]
Replied On June 7, 2013 03:50 AM UTC

Hi Hayssam,

 

Thanks for using Syncfusion products.

 

We are happy to hear that the issue has been resolved. Please let us know if you require any further assistance on this. We would be happy to help you out.

 

Regards,

Amsath Ali. M


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;