We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

How to Include scrollbar in gridgrouppingcontrol on expanding the selected columns

Thread ID:

Created:

Updated:

Platform:

Replies:

104829 Aug 22,2012 10:58 AM Aug 29,2012 11:44 PM Windows Forms 5
loading
Tags: Grouping
varsha
Asked On August 22, 2012 10:58 AM

Hi,

I have a gridgroupingcontrol which has 15 columns and I have dragged (selected) 5 columns. When I expand these selected columns, I'm unable to view the columns below as there is no scroll bar.

 


Athiram S [Syncfusion]
Replied On August 23, 2012 08:09 AM

Hi Varsha,

We have looked onto your problem.

The scroll bar will be automatically displaying when you drag the column.

Have you added any property especially for the scroll bar. If used such properties, make sure that the property is set to true.

Let me know if you have any concerns.

Regards,
Athiram S

varsha
Replied On August 24, 2012 02:50 AM

I have not used any property for the scrollbar, but the scrollbar does not appear for on expansion of column


Athiram S [Syncfusion]
Replied On August 24, 2012 07:22 AM

Hi Varsha,

Thanks for your update.

You can make use of the following properties and check.

this.gridControl1.VScrollBehavior = Syncfusion.Windows.Forms.Grid.GridScrollbarMode.Enabled;
this.gridControl1.HScrollBehavior = Syncfusion.Windows.Forms.Grid.GridScrollbarMode.Enabled;

Let me know if you have any concerns.

Regards,
Athiram S

varsha
Replied On August 25, 2012 04:14 AM

VScrollBehavior property does not exists. There are no property realted to scroll bar too.


Athiram S [Syncfusion]
Replied On August 29, 2012 11:44 PM

Hi Varsha,

Sorry for the delay.

As this is related to GridGroupingControl. Try with the following code:

 gridGroupingControl1.TableControl.VScrollBehavior = GridScrollbarMode.Enabled;
 gridGroupingControl1.TableControl.HScrollBehavior = GridScrollbarMode.Enabled;

If it doesn't work, try with 'Automatic' instead of 'Enabled' in the above code.

Let me know if you have any concerns.

Regards,
Athiram S

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;