We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

how to use a custom control in GridGroupingControl

Thread ID:

Created:

Updated:

Platform:

Replies:

104447 Jul 19,2012 08:06 PM UTC Jul 24,2012 12:37 PM UTC Windows Forms 5
loading
Tags: GridControl
Kymberley Dahl
Asked On July 19, 2012 08:06 PM UTC

I am trying to use a custom control in a GridGroupingControl and can't get it to work. All of the examples for custom controls I have seen are things that use standard items such as text, buttons, or datepickers, and mine is not any of those. It is a control which itself contains a picture and 2 labels. I have written a custom CellModel and CellRenderer but it just draws a blank cell. I am not sure what I specifically need to put into OnDraw to make it paint my control.

Ragamathulla B [Syncfusion]
Replied On July 20, 2012 05:02 AM UTC

Hi Kymberley

 

Thank you for your interest in Syncfusion products.

 

Please refer to the following samples which will be helpful for your reference.

 

http://www.syncfusion.com/downloads/Support/DirectTrac/95797/GroupingCell-1743634400.zip

 

http://www.syncfusion.com/downloads/Support/DirectTrac/94807/WindowsFormsApplication19-464366475.zip

 

Please let me know if you have any further concerns.

 

Regards,

Ragamathullah B.


Kymberley Dahl
Replied On July 20, 2012 04:36 PM UTC

Hi, actually I happened to discover the CellType of "Control" yesterday, and that worked perfectly for my needs. You guys should really add that one to the list of custom cell types that you have in both your online and offline documentation, would have saved me 2 days.

Ragamathulla B [Syncfusion]
Replied On July 23, 2012 04:11 AM UTC

Hi Kymberley,
 
Thanks for the update.
 
Please let me know if you have any further concerns.
 
Regards,
Ragamathullah B.
 
 

Kymberley Dahl
Replied On July 23, 2012 07:12 PM UTC

I seem to be having painting issues when I have a large number of records, whether the records are controls or simply text (I redid the entire thing to only use text and images instead of my controls to see if that would help - it did not). We use these grids in many other areas of our application with far more rows than the 800 I am using to test this, and those do not have painting issues. I'm also getting an out of range exception every so often. Who do I contact for my particular scenario for further support? This is getting frustrating.

Ragamathulla B [Syncfusion]
Replied On July 24, 2012 12:37 PM UTC

Hi Kymberley,
 
We regret for the inconvenience caused.
 
Am afraid that am unable to reproduce your reported issue. So i would request you to provide simple sample that replicate your reported issue which is helpful for us to provide better solution to you.
 
Appriciate your patience.
Regards,
Ragamathullah B.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;