We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Accordian - not showing

Thread ID:

Created:

Updated:

Platform:

Replies:

103879 Jun 6,2012 04:10 PM UTC Jun 11,2012 11:29 AM UTC ASP.NET MVC (Classic) 3
loading
Tags: Tools
Ross Macintyre
Asked On June 6, 2012 04:10 PM UTC

Hi

This is probably as simple setting that I am missing however I have followed the documentation and examples in creating an accordian within an MVC application however within the designer, the "Html.Syncfusion" is highlighted saying that it is not a member of System.Web.Mvc.HtmlHelper.

<%=Html.Syncfusion().Accordion("myAccordion")%>

I have added all the entries to my web.config however the accordian does not appear as expected.

Any idea what I am missing?

Regards

Ross

Meena [Syncfusion]
Replied On June 7, 2012 04:36 AM UTC

Hi Ross,

 

Thanks for using Syncfusion products.

 

We have prepared a simple sample with Accordion as per the steps suggested in our documentation and we did not face any issue as reported. The sample can be downloaded from the attachment.

 

We suspect that the reported issue may occur if the namespaces are not added or if the assemblies are not referred, kindly check whether you have added the following lines in your web.config file,

 

<code>

[Assemblies]

        <add assembly="Syncfusion.Core, Version=10.204.0.56, Culture=neutral, PublicKeyToken=632609b4d040f6b4"/>

        <add assembly="Syncfusion.Shared.Mvc, Version=10.204.0.56, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89"/>

        <add assembly="Syncfusion.Tools.Mvc, Version=10.204.0.56, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89"/>

 

[Namespaces]

        <add namespace="Syncfusion.Mvc.Shared"/>

        <add namespace="Syncfusion.Mvc.Tools"/>

 

[Handlers]

<httpHandlers>

<add verb="GET,HEAD" path="MvcResourceHandler.axd" type="Syncfusion.Mvc.Shared.MvcResourceHandler, Syncfusion.Shared.Mvc, Version=10.204.0.56, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89" validate="false"/>

</httpHandlers>

 

<handlers>

<add verb="GET,HEAD" name="MvcResourceHandler" path="MvcResourceHandler.axd" type="Syncfusion.Mvc.Shared.MvcResourceHandler, Syncfusion.Shared.Mvc, Version=10.204.0.56, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89"/>

</handlers>

</code>

 

If you creating your application with MVC3 Razor view engine, the following namespaces should also be added in the web.config file within the Views folder

 

<code>

[Namespaces]

        <add namespace="Syncfusion.Mvc.Shared"/>

        <add namespace="Syncfusion.Mvc.Tools"/>

</code>

 

Kindly check the above suggestion and attached sample and let us know if it helps.

 

Regards,
Meena



AccordionTest_Sample_cd64f081.zip

Ross Macintyre
Replied On June 8, 2012 09:03 AM UTC

Thanks for this, although I had all these settings in the my web.config. Turns out that I needed to ensure that I was running MVC 3 for this to work (was running 2)

Ross

Meena [Syncfusion]
Replied On June 11, 2012 11:29 AM UTC

Hi Ross,

 

Thanks for the update.

 

We are unable to reproduce the issue in MVC2 too.Accordion is working fine in MVC2.  Kindly download the Accordion MVC2 sample from the below link.

 

Please let us know if you have any other concerns.

 

Regards,

Meena



SyncfusionMVCApplication1_1e0f1be5.zip

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;