We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Unicode character (Korean language) duplicate problem in GridControl

Thread ID:





100976 Sep 16,2011 10:30 AM UTC Sep 20,2011 05:11 AM UTC WinForms 1
Tags: GridControl
Asked On September 16, 2011 10:30 AM UTC

There is a problem while input Korean character in grid controls
(specially GridDataBoundGrid, GridGroupingControl)

When I try typing Korean character in grid cell,
the first character is duplicated.
I changed ActivateCurrentCellBehavior = GridCellActivateAction.SelectAll,
but it didn't fix the problem.

There was a thread about similar problem http://www.syncfusion.com/support/forums/tools-windows/47341,
but the link "Defect #2499 - EditControl duplicates Japanese or Korean characters when Enter key is used." is not available now.

OS : Windows7 (Korean)
Syncfusion Version: 8.303.0.21

Thank you

Ragamathulla B [Syncfusion]
Replied On September 20, 2011 05:11 AM UTC

Hi Trans,

Thank you for your interest in syncfusion products.

You can achieve your desired using UseRightToLeftCompatibleTextBox property. The following code explains the same.

Grid.Model.options.UseRightToLeftCompatibleTextBox = true;
ActivateCurrentCellBehavior = GridCellActivateAction.SetCurrent

Let me know if you have any further concerns.

Ragamathullah B.


This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

or the page will be automatically redirected to sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon