We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

How to resolve Assembly manager issue in Framework 4.7 installed machine?

We had an issue in latest Windows 10 and Visual Studio 2017 update installed machine. Syncfusion Assembly Manager will detect the .NET Framework version up to 4.0 only. Framework 4.5, 4.5.1 and 4.6 will be in disabled state.

We have already fixed the reported issue at our end and the fix has been included in our 2017 Volume 1 Service Pack 2 release (15.1.0.41). 

Also, we have provided patches for this issue for the below Syncfusion versions. Follow the steps suggested below and apply the patch for the respective versions.

1. Download and extract the patch for the required version below.

Syncfusion version

Download link

15.1.0.33

Syncfusion_v15.1.0.33

 

14.4.0.20

Syncfusion_v14.4.0.20

 

14.4.0.15

Syncfusion_v14.4.0.15

 

14.3.0.52

Syncfusion_v14.3.0.52

 

14.3.0.49

Syncfusion_v14.3.0.49

 

14.2.0.32

Syncfusion_v14.2.0.32

 

14.2.0.28

Syncfusion_v14.2.0.28

 

14.2.0.26

Syncfusion_v14.2.0.26

 

14.1.0.46

Syncfusion_v14.1.0.46 

 

14.1.0.41

Syncfusion_v14.1.0.41

 

13.2.0.34

Syncfusion_v13.2.0.34

 

13.1.0.21

 

Syncfusion_v13.1.0.21

11.2.0.25

Syncfusion_v11.2.0.25

 

 

2. Take a backup of InstallInfoGenerator folder from the below location.

Location:
{ProgramFilesFolder}\Syncfusion\Essential Studio\{version}\Utilities

Example:
C:\Program Files (x86)\Syncfusion\Essential Studio\{version}\Utilities

3. Copy and replace the InstallInfoGenerator folder from the extracted zip file to the above location.

4. Open the command prompt with Administrative privileges (Admin mode).

5. Navigate to the Assembly.bat file from the extracted zip file location and click enter.


6. Open the Syncfusion Dashboard/ Control Panel and click the Recheck button at the bottom. 

Syncfusion Dashboard: Start Menu -> Syncfusion Dashboard {Version} 

Syncfusion Control Panel: Start Menu -> Syncfusion Control Panel {Version}

7. Launch the Syncfusion Assembly Manager, frameworks 4.5, 4.5.1 and 4.6 will be enabled now. As Syncfusion assemblies for frameworks 4.5, 4.5.1 and 4.6 will not be present in your machine, run the Assembly Manager utility for these frameworks. Now framework 4.5, 4.5.1 and 4.6 assemblies will be installed in GAC. Refer the following documentation link to for more information regarding Assembly Manager.

https://help.syncfusion.com/common/essential-studio/utilities#assembly-manager  

 

Article ID: Published Date: Last Revised Date: Platform: Control:
7989 09/15/2017 04/02/2018 Miscellaneous Install and Configuration
Tags:
Did you find this information helpful?
Comments
Chrisjan Mouton Sep 27, 2017
After doing this the Syncfusion Dashboard refused to run so i copied the original InstallInfoGenerator bact to where it was, i did not rerun the assembly .bat and then when I opened the Syncfusion Dashboard i could see 4.5.1 etc and I could continue.


Reply
Ali Asgar Vardawala Nov 12, 2017

I too had the same problem that Mr. Chrisjan mouton mentioned. Thus I applied his solution and it worked for me as well. 

Thank you Chrisjan :)

Reply
Atlante Dev Team Dec 01, 2017

Hi,

We have the same problem with version 14.1.0.41, but after run Assembly.bat, 4.5, 4.6 frameworks are still disabled on AssemblyManager...

Any idea ?

Reply
Add Comment
You must log in to leave a comment

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon