We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

After upgrading to a newer version, when i try to run my application i get "Invalid Resx File" error.

 

.ResX files may contain version specific information depending upon exactly what resources are being saved in the file.So, if you are migrating to a newer version of Essential Grid from an earlier version and have used the grid designer to setup the grid, in most cases you will need to migrate the .ResX files to the newer version of Essential Grid. Attached is a zip file containing a tool called ConvertResX.exe which, you can use to perform this migration.

There are couple of ConvertResX.exe's attached. One is compiled with 1.0 (use this if your development enviroment is VS.NET 2002 - 1.0 Framework), the other is compiled with 1.1 (use this if your development enviroment is VS.NET 2003 - 1.1 Framework)

Steps to do the migration:

1.Run the ConvertResX.exe application to see this screen.

Please refer the picture

2.Make sure the BaseVersion entry is the version number of your currently installed Syncfusion assemblies. You can see this version number in your .NET GAC folder, c:\Windows\assembly.

3.Click the Choose ResX Files To Convert button and select the resx files you want to convert.

4.Click the Start converting Files button.

5.After the conversion, the new resx files will have the same name as the original files. Copies of the original files will be present with a .OLD suffix added to their names.

Article ID: Published Date: Last Revised Date: Platform: Control:
450 04/30/2011 07/10/2014 Windows Forms General
Tags:
Did you find this information helpful?
Add Comment
You must log in to leave a comment

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon