We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Resolving the “Could not load type 'System.ServiceModel.Activation.HttpModule'“ error when running the ASP.NET or ASP.NET MVC sample browser

Platform: Miscellaneous |
Control: Install and Configuration |
Published Date: March 22, 2013 |
Last Revised Date: July 10, 2014 |
Product Version: 11.1.0.21
Tags: build, iis-error

This issue may arise if you have installed Syncfusion Essential Studio with all the product components including Silverlight in the IIS-configured machine. This is a known issue, and it will be fixed starting from version 11.x.x.xx of Syncfusion Essential Studio.

As a workaround, you can resolve it by running Aspnet_regiis.exe with the below arguments to re-register the correct version of ASP.NET in the IIS web server.

1. Open the command prompt with administrative privileges and navigate to the the Aspnet_regiis.exe file, which can be found in one of the following locations:

  • %windir%\Microsoft.NET\Framework\v4.0.30319
  • %windir%\Microsoft.NET\Framework64\v4.0.30319 (on a 64-bit computer)

2. Run Aspnet_regiis.exe with the following arguments: aspnet_regiis.exe /iru

3. Refresh the IIS web server or run the iisreset command in admin mode and restart the Syncfusion dashboard.

 

 

ADD COMMENT
You must log in to leave a comment

Please sign in to access our KB

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon