We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Eliminating the “Unable to locate any compatible version of the .NET Framework” error in Assembly Manager

 

The Assembly Manager utility is used to deploy or remove the Syncfusion assemblies in GAC. It uses the Gacutil.exe tool, which comes along with the corresponding framework SDK.

The Syncfusion Assembly Manager checks the registry entries under the following paths to verify that the framework SDKs are installed.

·       HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework

·       sdkInstallRoot -  For Framework 1.0 SDK

·       sdkInstallRootv1.1 - For Framework 1.1

·       sdkInstallRootv2.0 - For Framework 2.0 SDK

If there is no registry key in the above path, Assembly Manager will run into this exception: “Unable to locate any compatible version of the .NET Framework.”

To avoid this error, please perform the following steps:

·       Install the Framework 1.1 SDK from the link below.

Framework 1.1 SDK

·       Install the Framework 2.0 SDK from the link below.

      Framework 2.0 SDK

·       After installing the framework SDK, open Syncfusion Dashboard and run Assembly Manager.

·       Now you can deploy or remove the Syncfusion assemblies in the GAC and the assemblies folder.

Article ID: Published Date: Last Revised Date: Platform: Control:
2134 04/30/2011 07/10/2014 Miscellaneous Install and Configuration
Did you find this information helpful?
Add Comment
You must log in to leave a comment

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.