We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

can't copy picture to other presentation

Thread ID:

Created:

Updated:

Platform:

Replies:

141913 Jan 10,2019 10:36 AM UTC Jan 17,2019 10:35 AM UTC ASP.NET Core 5
loading
Tags: Presentation
Shuko Matsuura
Asked On January 10, 2019 10:36 AM UTC

I want to copy a group shape from presentation A to presentation B.  
And the group has a picture and two textboxes.

The code I write was completed,the textboxes are on presentation B,but there is not my picture and I see a red X on white square.

Which is the wrong point on my code?

my code:
 using (FileStream fileStreamTo = new FileStream(ResolveApplicationDataPath("presentationB.pptx"), FileMode.Open, FileAccess.Read, FileShare.Read))
            {
                FileStream fileStreamFrom = new FileStream(ResolveApplicationDataPath("presentationA .pptx"), FileMode.Open, FileAccess.Read, FileShare.Read);

                IPresentation presentationFrom = Presentation.Open(fileStreamFrom);

                ISlide slideFrom = presentationFrom.Slides[0];

                IGroupShape groupShapeFrom = slideFrom.GroupShapes[0];

                IShapes shapes = groupShapeFrom.Shapes;

                ISlideItem newgroupshape = groupShapeFrom.Clone();

                IPresentation presentationTo = Presentation.Open(fileStreamTo);

                ISlide slideTo = presentationTo.Slides[0];

                slideTo.Shapes.Add(newgroupshape);

                presentationTo.Save(ResolveApplicationDataPath("modified.pptx"));

                presentationTo.Close();
                presentationFrom.Close();
                }

Dilli Babu Nandha Gopal [Syncfusion]
Replied On January 11, 2019 11:31 AM UTC

Hi Shuko,

Thank you for contacting Syncfusion support.

We are unable to reproduce the reported scenario in our end, while performing group shape cloning with below attached documents by using your code example. We tried using latest Syncfusion.Presentaton.Net.Core package version v16.4.0.46. Could you please try your scenario with latest release version “16.4.0.46” and still if you are facing the same issue please share us with your source and destination documents since the issue might be document specific. 
Note: If you have any confidential data in your documents, please replace with some dummy data and provide us the same else share us at salessupport@syncfusion.com by mentioning this forum ID. 

Please find the source and destination documents which was used at our end to reproduce issue. 

Regards, 
Dilli babu. 


Shuko Matsuura
Replied On January 15, 2019 08:15 AM UTC

Hi Dilli babu,

Thank you for reply.
I tried the scenario with the presentation files which you attached,but same issue was happened.
So the issue maybe not document specific.

I'm using Free trial now,and its latest version is "16.4.0.42".
https://www.syncfusion.com/downloads

Can I try v16.4.0.46 for free?

Regards,
Shuko

Meikanda Nayanar [Syncfusion]
Replied On January 17, 2019 04:04 AM UTC

Hi Shuko,

Yes, you may try v16.4.0.46 for free. Please find the below link to download the trial version of NuGet with version ”16.4.0.46”.
https://www.nuget.org/packages/Syncfusion.Presentation.Net.Core/16.4.0.46
 
We have checked this with version - “16.4.0.42”.But, we are unable to reproduce the reported scenario from our end, while performing group shape cloning with both dummy data and also data provided from your side.
 

Please find the sample with dummy data which is created from our end to reproduce the issue using code snippet provided from your side.

 
If still you face the issue, please provide us your culture settings details. This will help us to proceed further in this. 

Thanks
Meikandan

Shuko Matsuura
Replied On January 17, 2019 09:21 AM UTC

Hi Meikanda,

I tried the code with new sample which made with Syncfusion ASP.NET Core (EJ1) Control Panel.
And then,the issue didn't occur...
I'm sorry for confusing you.

Regards,
Shuko

Dilli Babu Nandha Gopal [Syncfusion]
Replied On January 17, 2019 10:35 AM UTC

Hi Shuko, 
  
We are glad to know that the reported issue has been resolved. Please let us know if you need any further assistance on this. 
  
Regards, 
Dilli babu. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;