We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

MultiSelect control does not work in a modal dialog when mode="CheckBox"

Thread ID:

Created:

Updated:

Platform:

Replies:

141207 Nov 29,2018 04:11 PM UTC Dec 3,2018 04:56 AM UTC Angular - EJ 2 3
loading
Tags: MultiSelectDropdown
Michael Rodriguez
Asked On November 29, 2018 04:11 PM UTC

If you take your own sample application,https://stackblitz.com/edit/angular-m5h4j7 , and modify the multiselect control by adding Mode="CheckBox", you will see that it no longer works in the modal dialog. Is there a workaround for this?

Prince Oliver [Syncfusion]
Replied On November 30, 2018 05:48 AM UTC

Hi Michael, 

Thank you for contacting Syncfusion support. 

To use MultiSelect component in CheckBox mode, make sure that you have imported the MultiSelectAllModule in the app.module.ts file 

[app.module.ts] 
import { MultiSelectAllModule } from '@syncfusion/ej2-ng-dropdowns'; 
 
@NgModule({ 
  imports:      [ BrowserModule,DialogModule, FormsModule ,DropDownListModule,MultiSelectAllModule,CheckBoxModule], 
}) 


Now you need to define the mode as string. Kindly refer to the below code. 

[app.component.ts] 
public mode: string = 'CheckBox'; 

[app.component.html] 
<ejs-multiselect id='multiselectelement' #sample [dataSource]='countries' [fields]='localFields' [placeholder]='localWaterMark' [mode]='mode' [hideSelectedItem] = 'false' [value]='value1'>  
</ejs-multiselect> 

We have attached the modified sample for your reference, please refer to the following link: https://stackblitz.com/edit/angular-jjq8yu 

Regards, 
Prince 


Michael Rodriguez
Replied On November 30, 2018 04:00 PM UTC

Ok so the problem is that it specifically doesn't work in the Bootstrap modal dialog, it works in the SyncFusion modal dialog. I'm just going to switch to using the SyncFusion modal dialog instead.

Thanks!

Prince Oliver [Syncfusion]
Replied On December 3, 2018 04:56 AM UTC

Hi Michael, 

Thank you for the update. We are glad to know the issue is resolved in your end. Please let us know if you require any further assistance on this. 

Regards, 
Prince 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;