We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Annotation tooltip doesn't show when using crosshair.

Thread ID:

Created:

Updated:

Platform:

Replies:

140992 Nov 17,2018 12:54 PM UTC Nov 19,2018 09:09 AM UTC WPF 3
loading
Tags: SfChart
Tom
Asked On November 17, 2018 12:54 PM UTC

Hello, when using crosshair, annotation tooltips don't show.

Run the attached example. Hover the mouse pointer over the red circle. Tooltip doesn't show. Now comment out the xaml:

<chart:SfChart.Behaviors>
<chart:ChartCrossHairBehavior HorizontalLineStyle="{StaticResource lineStyle}" VerticalLineStyle ="{StaticResource lineStyle}"/>
</chart:SfChart.Behaviors>

to remove the crosshairs and run the test again. Now the tooltip shows.

Is it possible to have the tooltip displayed when using crosshairs?

Thank you.

Attachment: sfChartCrossHair_76fcc85e.rar

Muneesh Kumar G [Syncfusion]
Replied On November 19, 2018 07:09 AM UTC

Hi Tom, 
 
Greetings from Syncfusion, we have analyzed your requirement. We would like to inform you that this problem occurs due to cross hair line interrupts the annotation tooltip interaction. You can resolve this problem by setting IsHitTestVisible for cross hair line as per the below code snippet.  
 
Code snippet 
           <chart:SfChart.Resources> 
                <Style TargetType="Line" x:Key="lineStyle"> 
                    <Setter Property="Stroke" Value="Black" ></Setter> 
                    <Setter Property="StrokeThickness" Value="1"></Setter> 
                    <Setter Property="IsHitTestVisible" Value="False"/> 
                </Style> 
            </chart:SfChart.Resources> 
 
We have modified our sample based on this, please find the sample from the following location.  
 
 
Hope it helps.  
  
Regards,  
Muneesh Kumar G. 


Tom
Replied On November 19, 2018 08:44 AM UTC

That's a nice solution, thank you Muneesh.

Muneesh Kumar G [Syncfusion]
Replied On November 19, 2018 09:09 AM UTC

Hi Tom,  
 
Thanks for the update. 
  
We are glad to know that the given solution works. Please let us know if you need any further assistance. 
 
Regards,  
Muneesh Kumar G. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;