We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

local property doesn't work in version 2017 VOLUME 2

Thread ID:

Created:

Updated:

Platform:

Replies:

130427 May 11,2017 11:17 PM May 15,2017 08:27 AM Angular 3
loading
Tags: ejDateTimePicker
Jemmy Lu
Asked On May 11, 2017 11:17 PM

After update version to 2017 VOLUME 2 ,AOT works ,but when I use the locale property for datetimepicker like:
<input type="text" ej-datetimepicker id="ejdtp" [locale]="locale">
and in component:

export class SomeComponent {
     locale:string;
    constructor() {
        this.locale="zh-TW"
    }
}

same component works in previous version ,but now the datetimepicker always render as en-US ,it seems strange? 

Thanks.

Sasikala Nagarajan [Syncfusion]
Replied On May 12, 2017 08:21 AM

Hi Jemmy, 
Sorry for the inconvenience caused.  
 
We have checked with your query and created new support incident under your account to track this reported query. Please track that incident for further details by login with your Syncfusion account.   
  
 
 
Please let us know if you need any further assistance, 
Regards, 
Sasikala Nagarajan 


Jemmy Lu
Replied On May 12, 2017 12:04 PM

Thanks for replying,I would like to ask the correct way to setting up :In the previous version,I download syncfusion scripts by script generator to reduce the file size.And I have some localized files from the installed folder like en-US.js and other cultures.And finally I bundle the syncfusion scripts and localized js into one,and reference it in head tag.Now I update my version to VOLUME 2 and I notice it need to install syncfusion-javascript with npm,but the file is large,and I have no idea where to put localized files and just install components I want to use.Is there any idea?Thanks

sureshkumar.P [Syncfusion]
Replied On May 15, 2017 08:27 AM

Hi Jemmy, 
 
We think that you had updated the source for updating the localized source only by using the command for common “npm install syncfusion-javascript”. In this command, all files are (localized+script+themes) downloaded to your local machine that cause the larger file size.  
 
We recommend that you have update your scripts files using our Essential JS custom script generator utility (http://csg.syncfusion.com/). And if you want to update the localized files using “npm” please use bellow comment for updating the localized files to your local machine for reduce the file size and avoid the unwanted file download. 
 
To install minimal localized files:   $ npm install syncfusion-ej-global 
 
To install all localized files:  $ npm install syncfusion-ej-global-all 
If we misunderstood your query, please provide more information with our source updated command details (npm) and downloaded file size. This will be helpful for us to analyze and provide an exact solution at the earliest. 
 
Kindly get back to us if you need any further assistance.  
 
Regards, 
Sureshkumar P 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;