We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Headers don't always layout fully until data is loaded

Thread ID:

Created:

Updated:

Platform:

Replies:

130211 Apr 27,2017 04:29 PM Apr 28,2017 08:58 AM Xamarin.iOS 1
loading
Tags: SfDataGrid
Clint Anderson
Asked On April 27, 2017 04:29 PM

In some of my grids I am having issue with the headers not fully loading correctly until after the ItemsSource is loaded for the first time.  My grid will display with some of the headers being cut off, and then when the data finishes loading from the server, the headers will correctly finish rendering.

I believe it may be an issue when mixing column headers where some columns have a set width and others rely on ColumnSizer.Star.

Attached is an example of this issue occurring. It is easier to see the issue on the iPad, although it also appears on the iPhone in landscape. You will be presented with a button. When pressed, the grid should display with part of the last header not displaying correctly.  After 2 seconds, the data will load and the headers will size correctly.

Attachment: HeaderSizeDemo_8f08c737.zip

Pavithra  Sivakumar [Syncfusion]
Replied On April 28, 2017 08:58 AM

Hi Clint, 
 
A support incident to track the status of this defect has been created under your account. Please log on to our support website to check for further updates 
    
 
Regards, 
Pavithra S 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;