We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Migration tools from .net 1.1 to 4.x -> SF v4.2 to lastest

Thread ID:

Created:

Updated:

Platform:

Replies:

130061 Apr 19,2017 10:09 AM UTC Mar 5,2018 12:38 PM UTC General Discussion 3
loading
Tags: General Discussion
Michael Lacquemant
Asked On April 19, 2017 10:09 AM UTC

Hi,
I've an old application write with .net framework 1.1 and Syncfusion controls v4.201.0.37.
With the last version of syncfusuion i've the migration tools but it can only migrate from .net 2.0

Do you have any solution/tools for migrate my application easely ?

Manivannan Sundararajan [Syncfusion]
Replied On April 20, 2017 11:17 AM UTC

Hi Michael,

Thanks for contacting Syncfusion support.

Syncfusion has stopped providing the .NET Framework 1.1 support from Essential Studio version 7.1 and later. So, all the Syncfusion utilities from v7.1 doesn’t have .NET Framework 1.1 support.

Currently we are providing the support for Framework versions 2.0, 3.5, 4.0, 4.5, 4.5.1 and 4.6. Please download and install the latest Syncfusion Essential Studio v15.1.0.41 from the following link and upgrade your projects to the required framework version.

https://www.syncfusion.com/support/directtrac/downloads/15_1_0_41  

Regards,
Manivannan S.


mar
Replied On March 3, 2018 11:57 PM UTC

I went from dot net 1.1 to vs2017 with the following steps:
copy the dot net 1.1 project folder to a new folder
delete the licenses.licx file
open that copied project in vs2017 and finish the upgrade wizard
change the target dot net framework to a newer version
remove the references to the dot net 1.1 syncfusion assemblies
add in the references to the new syncfusion assemblies
save & exit
delete the "backup" folder that vs2017 creates under the copied folder
run the syncfusion control panel, select utilities/project migration, point to the copied folder, select the correct dot net framework version from the drop-down, select 'remove hint paths'



Kalap Johnson Peter Paulraj [Syncfusion]
Replied On March 5, 2018 12:38 PM UTC

Hi Mar,

Thanks for contacting Syncfusion support.

The provided steps to migrate .NET framework version from 1.1 to latest version is correct. Please refer the following documentation link for more information regarding Project Migration

https://help.syncfusion.com/common/essential-studio/utilities#project-migration

Regards,
Kalap Johnson Peter.P


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;