We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

WebApiAdaptor not defined in 'ej.web.all.d.ts'

Thread ID:

Created:

Updated:

Platform:

Replies:

127203 Nov 2,2016 03:33 PM UTC Dec 15,2016 06:33 AM UTC JavaScript 5
loading
Tags: ejDataManager
Maurits van Beusekom
Asked On November 2, 2016 03:33 PM UTC

Hi,

I am trying to write a custom adaptor based on the ej.WebApiAdaptor using TypeScript. However the typescript definition file seems to be missing the definition for the ej.WebApiAdaptor class (the UrlAdaptor, ODataAdapter and ODataV4Adaptor are included). 

Could you please add the WebApiAdaptor definition to the definition file? I am currently using the latest version "14.3.0.52".

Kasithangam C [Syncfusion]
Replied On November 3, 2016 09:25 AM UTC

Hi Maurits, 
We are able to reproduce the issue “WebApiAdaptor not included in typescript”. A support incident to track the status of this issue has been created under your account. Please log on to our support website to check for further updates. 
Please let us know if you have further concern. 
 
Regards, 
Kasithangam 


Aravind Ashokkumar
Replied On December 14, 2016 01:56 AM UTC

Hi Team,

I am facing the same issues, Could you please let me know if ej.WebAPIAdaptor is available under Typescript?

Regards,
Aravind

Prince Oliver [Syncfusion]
Replied On December 14, 2016 11:31 AM UTC

Hi Aravind, 
 
Thanks for contacting Syncfusion support. 
ej.WebAPIAdaptor is available in TypeScript from 2016, Volume 4 Release and It will not be available in releases prior to this version.  
 
Regards, 
Prince 


Aravind Ashokkumar
Replied On December 15, 2016 01:07 AM UTC

Hi Prince,

Could you please provide the exact version number of the Release ?

Regards,
Aravind

Prince Oliver [Syncfusion]
Replied On December 15, 2016 06:33 AM UTC

Hi Aravind, 
Thanks for your update. 
The version number for 2016, volume 4 release is 14.4.0.15 
Regards, 
Prince 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;