We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

RangeSlider's Tick & Label are not displayed when used inside ListView

Thread ID:

Created:

Updated:

Platform:

Replies:

125919 Sep 11,2016 08:39 AM Sep 12,2016 07:59 AM Xamarin.Forms 1
loading
Tags: SfRangeSlider
Keshav Kumar
Asked On September 11, 2016 08:39 AM

I've a list of actions in ListView each containing RangeSlider for marking progress by user. But the Ticks & Labels are not displayed (in UWP & iOS. I've not tested on Android). Tick & Label is displayed if its used outside ListView. Here is the code:

 <ListView ItemsSource="{Binding ActionSteps}" SelectedItem="{Binding SelectedActionStep, Mode=OneWayToSource}"
            HasUnevenRows="True">
    <ListView.ItemTemplate>
      <DataTemplate>
        <ViewCell>
          <Grid Padding="0,15,0,0">
            <Grid.RowDefinitions>
              <RowDefinition/>
              <RowDefinition Height="Auto"/>
            </Grid.RowDefinitions>

            <StackLayout>
              <Label Text="{Binding Action}"/>
              <rangeSlider:SfRangeSlider ShowValueLabel="True" ValuePlacement="TopLeft" TickPlacement="TopLeft" SnapsTo="Ticks" TickFrequency="1" 
                                         Minimum="0" Maximum="{Binding Repetitions}"
                                         ShowRange="False" Value="{Binding CompletedRepetitions, Mode=TwoWay}"
                                         HeightRequest="20" Margin="0,0,200,0" Orientation="Horizontal"/>
            </StackLayout>

            <Label Grid.Row="1" Text="{Binding Quote.Statement}" TextColor="Gray" FontSize="10"/>

          </Grid>
        </ViewCell>
      </DataTemplate>
    </ListView.ItemTemplate>
  </ListView>

RangeSlider with no Tick & Label

Pavendhan Kumar [Syncfusion]
Replied On September 12, 2016 07:59 AM

Hi Keshav,

Thank you for contacting Syncfusion support.

We were able to reproduce the reported issue “RangeSlider’s tick and label are not displayed when it is added in ListView” at our end. And logged a bug report for the same. The fix for the bug will be included in our Volume 3 SP 1 release which is expected to be rolled out by the end of October 2016.

Regards,
Pavendhan K.


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;