We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Richtexteditor update version fail

Thread ID:

Created:

Updated:

Platform:

Replies:

123895 Apr 29,2016 10:38 AM May 5,2016 09:15 AM ASP.NET Web Forms 7
loading
Tags: RichTextEditor
Roimer Machacón Otero
Asked On April 29, 2016 10:38 AM

Hi we're using richtexteditor, now when update to the version 14.1.0.41 this appear bad (Attached image with the error). What happen with this element?

Attachment: rte_error_7b821814.zip

Roimer Machacón Otero
Replied On April 29, 2016 11:23 AM

Hi we can see that in the browser console appear this error, This error in previous version that have not appear and the RTE work correctly

Uncaught Error: Syntax error, unrecognized expression: .e-menu-wrap #

Attachment: error_rte_86ada66d.zip

Gopi Govindasamy [Syncfusion]
Replied On May 2, 2016 12:35 PM

Hi Romier, 

Thanks for contacting Syncfusion support. 

Sorry for the inconvenience caused. We are unable to reproduce the reported issue from our end. We suspect that the reported issue “RTE rendered improperly” due to improper theme/script reference. To check this issue we have prepared the simple sample with the help of CDN references for Syncfusion related Scripts and CSS, but the reported issue is not reproduced.  
Please find the CDN reference links:  
 
 
Please replace these script and CSS from your sample and let us know whether the issue still persist in your end, then please share the reproducing sample with replication procedure that will help us to resolve the problem as soon as possible. 
Regards, 
Gopi G 


Roimer Machacón Otero
Replied On May 2, 2016 03:54 PM

Hi, we replace the files and the error persist

Roimer Machacón Otero
Replied On May 2, 2016 04:43 PM

Attached a project sample now only 2 buttons appear opened and damage the order of the RTE

Attachment: RTE_d2f933cd.zip

Gopi Govindasamy [Syncfusion]
Replied On May 4, 2016 08:39 AM

Hi Roimer,  
  
We have checked with your query and created a new incident under your account to track the status of the issue reported in this forum. Please log on to our support website to check for further updates.  
  
Regards,  
Gopi G  


Roimer Machacón Otero
Replied On May 4, 2016 09:57 AM

Hi, I found a solution for this incident, to the name of the RTE remove the "__" this was added because Asp.Net show first this error "A potentially dangerous Request.Form value was detected from the client (MainContent_DefaultRTE_formatDDL="<p>")."

With this in the web.config:
<system.web>
<httpRuntime  requestValidationMode="2.0" />
<pages validateRequest="false">
</pages>
</system.web>

And the name with __ solved the error, now this in the version 12.4.0.36. Updating to the version 14.1.0.41 maintain the web.config with those lineas and removing the "__ of the RTE name, work correctly

Gopi Govindasamy [Syncfusion]
Replied On May 5, 2016 09:15 AM

Hi Roimer,  
we have updated the response in related incident which was created under your account. kindly follow up for further updates. 
Regards,   
Gopi G 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;