We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Node adorner doesn't rerender after zooming

Thread ID:





123708 Apr 13,2016 08:15 AM UTC Apr 20,2016 12:51 PM UTC WPF 5
Tags: Diagram
Petr Cesak
Asked On April 13, 2016 08:15 AM UTC

I need to create a node with the adorner decorator, which will redraw after zooming in. I have successfully assigned the Adorner to the Node, but zooming (Ctrl + MouseScroll) occurs only on the Node. Please advise me how to implement adorner to zoom together with the Node.
I attach a simple demonstration project in VS2013.

Thank you,

Attachment: CircleAdornerTest_39636a62.zip

Ranjitha Amirthalingam [Syncfusion]
Replied On April 14, 2016 12:28 PM UTC

Hi Petr,

Thanks for contacting Syncfusion Support.

We are able to reproduce the reported scenario “Framework CircleAdorner is not Zoomed together with Node” while using Node (Diagram Element). So, we have tested the reported scenario with Framework Element(Button), which behaves the same. We have provided the video and modified sample (with framework elements) to represent this. Please refer to the sample and video as below.

Video Link:

Sample Link:

Ranjitha A.

Petr Cesak
Replied On April 14, 2016 02:02 PM UTC

Hi Ranjitha,
thank you for response.

Your video link and sample link contain the same video file. I can't find sample project.
After watching the video I agree. Any adorner assigned to FrameworkElement in Diagram control behaves the same. Probably won't be a problem in the Node element, but in Diagram control and its zoom function. I need a Diagram to call InvalidateVisual after zooming, but I couldn't find any relevant event. Your answer don't give me any satisfactory solution.
I tried to create the same example with the SfDiagram control and it works correctly. Unfortunately my project profusely uses Diagram control and it would be so difficult to rewrite it.


Ranjitha Amirthalingam [Syncfusion]
Replied On April 19, 2016 12:53 PM UTC

Hi Petr,

Sorry for the inconvenience caused.

Reported scenario:  CircleAdorner is not Zoomed together with Node.
We have provided animation support for ZoomIn/ZoomOut functions in DiagramControl which causes the reported scenario. The animation of the DiagramView can disabled by AnimationEnabled property of the DiagramView. Please refer the following code example to disable the animation.

Code Example:

diagramView.AnimationEnabled = false;

//here diagramView is an instance of the DiagramView

Ranjitha A.

Petr Cesak
Replied On April 19, 2016 03:10 PM UTC

Hi Ranjitha,
I certainly appreciate your help.

Unfortunately your advise does not work for my diagram. Everything behaves the same as before, only animation has been removed.

modified file MainWindow.xaml from sample CircleAdornerTest:
                <syncfusion:DiagramModel x:Name="diagram" />
                <syncfusion:DiagramView AnimationEnabled="False" />

I use Syncfusion version (Syncfusion.Diagram.Wpf.dll, 13.4400.0.63).
Could you send me a fixed VS project or video for inspiration, please.


Ranjitha Amirthalingam [Syncfusion]
Replied On April 20, 2016 12:51 PM UTC

Hi Petr,

We have confirmed that the reported issue “CircleAdorner is not Zoomed together with Nodeas an issue and a support incident has been created under your account to track the status of this issue. Please log on to our support website to check for further updates.



Ranjitha A.


This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

or the page will be automatically redirected to sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon