We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Disable auto sorting process while we are editing the existed records or adding a new records in the grid.?

Thread ID:

Created:

Updated:

Platform:

Replies:

109440 Jun 13,2013 06:05 AM UTC Jun 19,2013 04:20 AM UTC WinForms 1
loading
Tags: GridControl
Saikrishna
Asked On June 13, 2013 06:05 AM UTC

Hi.
Please suggest me any good solution to the below case.
In my project for the GridDataBoundGrid control, we have 2 modes and they are view, create/edit mode.
1).In 'View' mode as the grid is only readable only there is no problem in sorting the grid by using 'CurrecyManager' class.
2).In 'Create/Edit' mode as the grid is changeable (i.e we can edit the values) while we are doing sorting on one column and when we are editing the values it is applying sorting on the respected column values and the row which we change is positioned to another location in the grid based on the sorting criteria.
It is looking like the row is jumped to another location which is very inconvenient to my users.

How can I disable auto sorting process while user editing the existed records or adding a new records in the grid.?

Please respond back as soon as possible as it is very urgent work for my users.


Vinish Kumar K [Syncfusion]
Replied On June 19, 2013 04:20 AM UTC

Hi Saikrishna,

 

Thank you for your interest in Syncfusion products.

 

Query

How to disable the auto sort in GDBG

We have analyzed the reported query in our end. You can disable the auto sort while the cell is updated using the event cell_Click and wrapclass. Please refer the below UG link for further reference.

 

http://help.syncfusion.com/ug/windows%20forms/grid/default.htm#!Documents/howtodisablesortingw.htm

 

and the below UG is used to know more details about disable and enable the sorting in GDBG. Please refer this also.

 

http://help.syncfusion.com/ug/windows%20forms/grid/default.htm#!Documents/434321enableordisablesorting.htm

 

We hope this will resolve the reported issue in your end. Please let me know if you have any concerns.

 

 

Regards,

Vinish.


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;